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Buffers and land cover around cases
Introduction
In this lab you’ll examine land cover (LC) data at multiple scales around cases. Comparing types of LC close to the cases with types further away should give insights into environmental factors related to the cases.

The word “environment” a very common—and much abused—term. Here I use it to mean both land cover phenomenon measured in the study area as well as the spatial neighborhoods of our case data. 

Case mapping

Data management

Create a projects/environment directory.

Download the environment/data.zip file and unzip in the directory (see the useful information document for instructions). You should then have a directory named projects/environment/data containing various files.

Create a cases spreadsheet

You’ll create a spreadsheet for the case data and use it to add points to the map.

Run Excel and File > Open > File name: projects\cases.txt then Next, Next, Finish. 

Then save the data as a spreadsheet: File > Save As > type: Excel workbook and name: cases.xls.

EXTRA Open cases.txt in Notepad just to see that it’s just a simple tab-delimited file—a very convenient way to transmit data.

EXTRA From prior labs we know that there are many kinds of analysis you can do on these case data with Excel (or any statistical application): scatter plots, time series, pivot tables. You are encouraged to return to this step, re-open this file and do some of this analysis.

Close Excel.

Add cases data to the map

Run ArcGIS with an empty map and then select Tools > AddXY data > browse to: cases.xls then select Name: cases$ then Add and X: east and Y: north.

Under Coordinate System select Edit > Import > Name: select landcover then Add and 3 OKs. You should see the cases plotted as points floating on the map.

In order to analyze the case data and relate to other layers they have to be a shapefile. Right-click on the layer cases$Events > Data > Export > cases.shp then OK and Yes. Right-click cases$Events and Remove it. 

Spend a few minutes looking at the distribution of cases. What kind of pattern do they make: random, clustered, dispersed, etc? As you move the cursor around your map you can see their coordinates at the lower-left of the window—what’s the approximate extent of the data east-to-west and south-to-north?

From the ESRI templates directory add other map data. If you don’t know where the cases are, starting with world > continents is appropriate.

2 standard deviation circle

A simple way to understand the nature of a point pattern is to make a circle around the data, here you’ll make a circle that encompasses 2 standard deviations of the cases. 

Select Toolbox > Spatial Statistics > Geographic Distributions > Standard Distance > Input: cases, Output: data\2SD.shp and Circle: 2 Standard Deviations. Close the tool when it completes. (You must save this shapefile in your project or data directory.)
Select the circle and zoom to it, note how it includes almost all the cases. Think about what such a SD circle is (look at the help file for the tool!).
Open the Attribute Table for this feature and see where the center of the circle is, and what its radius (StdDist) represents. You can also get twice this from its Properties > Source > Extent.

EXTRA How many cases would you expect within the circle? How many are actually in the circle (hint: count those that aren’t in the circle and subtract from the total). 

EXTRA

You could also do a Select by location to find the cases in the circle.
Point pattern analysis is a rich field for medical geography. You can use Spatial Statistics Tools for this.
Density analysis using Spatial Analyst (SA) provides a surface, as we did for the reports in the earlier lab.

Also you could add US states or counties and do a ‘spatial join’ to see which of these regions have cases. Then you could do some incidence analysis as we’ve done earlier.
Land cover mapping
Map the land cover data
The primary research goal is to see if different land cover are associated with the cases.

Add the landcover raster data and zoom into to a few pixels (around 1:100,000) to examine its structure. Then zoom out to this layer or beyond (~1:10 million) to see what the whole dataset looks like. 

Select the landcover layer and right-click > Properties > Symbology > Value Field: DESCRIPTIO. If you wish, select another Color Scheme.

Note that the Count column is simply the number of cells in each LC VALUE class.

Add state, and neighboring countries maps.
NOTE: The management of raster colors is difficult, so you’ll notice that the color assigned to a given LC class will change with each of the extracts. Sorry…but if you’re esthetically inclined, create a color scheme, at least for the important LC classes!
Examine land cover data

Right-click landcover > Open attribute table. Click on various rows to see where the corresponding landcover types are found. E.g. Select Developed and Partly developed to see where urbanization is found; or click the various croplands, etc. What is the largest class? Where are some of the smaller classes?
Select the Identify button (black dot with a white ‘i’) to see what kinds of land covers there are in various locations.
DISCUSS: Which of the above two steps correspond to the questions “Where is y?” and “What is at x?”

*Export the landcover table

If necessary, be sure to clear all the selections before going on by going to the Menu and Selection > Clear Selected Features.

For our land cover analysis, you’ll need a table to store the LC statistics.

In the Attributes table click Options > Export > Output: lc_counts.dbf and OK, and Yes to add it to the map.
Close the attribute table.

Go to Table of Contents > Source tab and right-click on the lc_counts table then Open it. This is the table where you’ll add various counts from other scales of analysis. You can keep it open but minimize it or at least move it out of the way.
*Asterisks are to help you find your way back to these steps.
Land cover statistics

LC for the 2SD disk
You’ll first examine the land cover distribution in the circle by using the 2SD circle to ‘cut out’ only the LC within it. You’ll need the Spatial Analyst extension – again, see useful information document for instructions if this extension isn’t available.
Select Toolbox > Spatial Analyst > Extraction > Extract by Mask then Input raster: landcover and Input feature: 2SD and name the Output: lc_2SD. then OK and close the dialog when it’s finished.
You now have a disk representing the land cover within 2 standard deviations of the center of the cases. This is our ‘base’ LC distribution for the study.
Export the LC counts for the 2SD disk

You’ll next export a table containing LC counts for the extracted disk.

Right-click on the lc2SD extract (a multicolored disk) and open its Attribute Table.  In the Attributes table click Options > Export > Output: lc_2SD.dbf and OK, and Yes to add it to the map.

Close the attribute table, and go to the Table of Contents > Source tab and note that you now have 2 tables.

*Join the 2SD land cover to the full land cover data table
Select the Table of Contents > Source tab and right-click the table lc_counts > Join and 1. field: VALUE, 2. table: lc_2SD and 3. field: VALUE then OK and Yes.
Now look at the lc_counts table and examine what you have done. 

You have a table that compares the LC cell counts for the whole land cover raster (the first COUNT column) as well as the 2 SD disk (the second COUNT column). The latter presumably tells us more about land cover in the study area than the arbitrary scene.

Note for example that some of the smaller LCs aren’t even in the disk, so it is clearly different from the whole raster.

Give the cases larger symbols to see how their locations may relate to various LC classes.

Sort lc_COUNT descending to see which VALUEs are most and least frequent. Compare the order of the 2SD counts—which are unusually common in the disk but not in the scene?
EXTRA

Right-click on the various columns to see what kinds of distributions they have. Some are merely nominal values but others are measurements of something.

Study the table. What is VALUE and its range, COUNT and its sum, range? What kind of distribution does COUNT have?

Examine LC buffers around cases
Create buffers around each case
You could now compare LC in the disk with the whole raster, but let’s take this to a finer scale by examining a 10-kilometer neighborhoods of the cases.

Arc Toolbox > Analysis > Proximity > Buffer then Input: cases, Output: data\10km_buff.shp and Distance: 10000 (meters) and OK, then close the dialog when it’s finished.
In the Table of Contents (ToC) arrange the layers in the following order: cases, 10km_buff, lc_2SD and landcover. Turn off the 2SD disk and select No Color for the fill of the buffers.
Zoom in on a few cases layer to see what you did. The discussion of this would be an appropriate narrative for the “Methods” section of a research paper!
Extract land cover for the buffers
Just as you extracted LC for the big circle, now you’ll extract LC for the smaller buffer circles.
Toolbox > SA > Extraction > Extract by Mask then Input raster: landcover and Input feature: 10km_buff and output: lc_10km and OK, closing the dialog when it’s finished. Still zoomed in on your cases, now think about what you did. 
The colors of the circles don’t match but the patterns will!
Join the LC counts to the overall LC table
*Refer to the earlier asterisked steps in what follows.

As you did with the 2SD circle LC data, open the lc_10km attribute table then export to lc10_km.dbf and add to map and close table.

Go to ToC > Source and right-click on LC_counts table then Join and 1. field: VALUE, 2. table: lc10_km and 3. field: VALUE then OK and YES.

Again, look at the LC_counts table to see what you got. All the available values were matched. 

Export this table to landcover_counts.dbf.
Extra (for later!)
Do the analysis for other buffers, say 5 km or 20 km…
Even if you don’t do this, what answers do you expect to get?
STOP and take a rest!

LC count analysis

Discuss and consider

You have examined LC statistics --COUNTS of land cover VALUEs--for the whole study area, a large circle containing almost all of the cases, and 10-kilometer buffers around the cases. 
You have joined (merged) these counts into one database table. You can now see if the land covers near the cases are different from the whole study area. As this is data analysis and not spatial analysis, you’ll need Excel (or some other analytical package).
LC cell count description
Run Excel and open landcover_counts.dbf, then save it as land_cover_counts.xls.
For each LC code row you should have columns representing VALUE,  DESCRIPTION and several COUNTs. Rename the first COUNT column with the name RASTER, rename COUNT_1 column with the heading 2SD, and the COUNT_12 column the heading 10KM. Move (cut and insert) the RASTER column after the DESCRIPTION column. You should have columns named VALUE, DESCRIPTIO, RASTER, 2SD, 10KM. and delete the other columns.
Your spreadsheet should look something like the following:
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1 | vALUE DESCRIPTION | RASTER  2sp 10wt
2 1 Developed Tea0 2192 sse
3 2bry Cropland ¢ Pastus 4272 652 71
1 3 Irrigated Cropland | 32892 7ess 523
5 SCropland/Voodland 31363 2863 208





Examine the table to see what it contains and think about what it shows.

LC count analysis 
Create a total row for each of the count columns. First type TOTAL in the last cell of the DESCRIPTION column and to its right (E.g. in the first empty cell of the RASTER column) type =sum(C2:C22), then copy this formula to the next two cells. Note the differences in the total cells (i.e. areas) of these three datasets. About what are the ratios between them?
The 2SD circle includes almost all the cases but has different LCs from the full raster. Similarly, the buffers contain all the cases but a much more focused LC description.
Compute the proportions of LC for each column. First, copy the 3 data column headings to the tops of the first 3 empty columns. Then in the first empty cell under RASTER type the formula =C2/C$23 (note the $ meaning an absolute row reference) Copy this formula across to the next 2 rightmost cells, and then copy down the empty range. Format these 3 new rows as percentages with 1 decimal place
You should have 3 columns totaling 100% but each with different proportions. Visual analysis should suggest which LCs are more—or less—common near cases.
A quick way to understand the environments around the cases is to examine the most frequent land covers for the buffer circles. Select all but the TOTAL row and then at the menu Data > Sort > Sort by: (2)10KM and Descending then OK. This puts the most common buffer LC types at the top

DISCUSS which LCs are most common around the cases? How do these percentages compare with the other scales of analysis (raster and 2SD circle)?
Location quotient analysis

Another powerful way the compare data among regions is the location quotient.

Type QUOTIENT in the first empty topmost cell. Then below it type the formula =H2/G2. Some of the results will have error values; replace them with the value 0 (zero).

Think about how the location quotient compares to relative risk in that it represents the relative chance of finding a certain LC near versus far from a case.

Look where the quotient is high or low. Which LC types are more associated with the cases, and which less? Discuss your findings.

Discussion

This is a very intricate exercise—as if you didn’t know! If you have completed it you should have learned which land cover types are more or less common in the study area and, compared to the whole region, which are more or less associated with the cases
The high location quotient for developed lands is almost certainly mainly due—as often the case—to the presence of a population at risk! 
But there are LCs that appear to be unusually associated with the cases (which?) or unusually absent around the cases (which?). This is the essence of environmental analysis.

You have also had an excellent introduction to 1) how map data are displayed and visually compared, 2) how to use a few essential geographic tools, and 3) a fundamentally important approach to scale and counts, frequencies, proportions, and quotients—not to mention spatial association.
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