Mapping reports
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Tracts, density, and points.
Introduction

This lab exercise maps reports of incidents in the city of Philadelphia. For the analysis we don’t have to know more than this because the techniques used apply to the exploration and analysis of any event data. Our assignment is to map these reports, visualize the patterns made by them, and relate the incidents to other variables. You are welcome to explore the data in any way you wish, but begin by trying the tasks below.

This lab has many steps that can be confusing and may even have errors, so please let me know about any problems you have. But even if the steps are successful, please take a few minutes to study what results you get at each step: charts, maps, statistics, etc. This insight is at least as important than the technical expertise you are also acquiring!

The lab concludes with an assignment asking you to methodically discuss what you have done and your conclusions.

NOTE: Please do not circulate these data as they are for educational purposes only!

Data exploration

Data management

Begin by creating a projects\reports folder for your work.
Download the reports.doc to your folder.

Download the reports.zip file and save it to the Desktop, then unzip it to your folder, where it should create a projects\reports\data folder. Don’t worry if these files don’t end up exactly where the instructions indicate, so long as you can find them.
Examine the data

Run notepad and open reports.txt (you can also open it in Word or any other editor, but don’t save it. 

Consider this data matrix. How many columns (variables) are there? What are the S/T/P (space/time/phenomenon) variables and what are their units? About how many reports are there? 

Examine the time variables. What is being measured here? What is the level of resolution and accuracy? Can you think of another way of representing these data?

Create a spreadsheet
Run Excel then select File > Open > Files of type: Text then browse to reports.txt and select the file. 

When the wizard comes up select Delimited, then make sure Tab is selected and Next and Finish.

Before doing any further analysis in the spreadsheet you need to save it for later import to ArcGIS. Select File > Save As > Type: Workbook then Save as reports.xls.

NOTE: any further analysis you do on this spreadsheet should NOT be saved under this name, so you might want to save the data under a new name and proceed to the next step.

Examine the data further. How many reports are there?

Although Excel is not a GIS—and the spatial variables are not projected—nevertheless make a scatter diagram of the spatial variables and discuss the pattern.

Do Data Analysis on the columns; e.g. what are some statistics for LON and LAT?

EXTRA: How might you make a reasonably correct ‘projected’ plot of the points?

Time series

The spreadsheet does support temporal analysis, as was done in a previous lab.

Use pivot table to count the reports by year and month. Make one or more charts (line, bar, etc). DISCUSS the results in terms of trend and/or seasonality.

Do Data Analysis on the time variables.

NOTE (repeat): if your spreadsheet has been enhanced with further analysis, save it under a new name and not reports.xls.

Point mapping

Open the map data

Run Arc GIS, open an empty map, then add the image and tract data from your project/data folder. Note that in an effort to keep the datasets small I’ve only included two images. What are they and how many might be needed for a complete coverage of the city? Where might you get them?

From the ArcGIS template database (see useful information at the beginning of the lab page) add US states (and counties if you wish).

Examine the map so far by zooming and turning off layers.

Map only the tract outlines by selecting the tract symbol (colored rectangle) and selecting Options > Fill Color > No Color. You can also change the Width and Color of the outline.

Add points to map

In ArcGIS select Tools > AddXY > browse to reports.xls and select it then Add and select the reports$ table and Add. Make sure X: LON and Y: LAT are selected. 

In order to make sure the points are plotted on the map correctly we need to select the coordinate system. 

Find Coordinate System > Edit > Select > Geographic > World > WGS_1984.prj then Add and click all the OKs to finish. You should see a cloud of points on your map.
Finally, in order to work with the report points we need to save them as a shapefile: Select the events and then Right-click > Data > Export project\reports\reports.shp then OK and OK.

Move the reports layer to the top of the Table of Contents then right-click on it and see that it has all of the original columns plus new ones (what are they?).

Remove the Events layer.

Examine patterns visually

Make sure the reports layer is visible and discuss any patterns you see. Is the pattern dispersed, random, clustered…neither, both?

Where (if any) are clusters, outliers, ‘null’ regions where no reports were allowed?

EXTRA (thought experiment): Think about larger-scale clustering? Why are there no reports outside of the city? How might a pattern beyond the city look, say at the county, state, national, planetary, solar system level? You don’t have to know what the reports are to speculate about these questions.

With either of the images checked zoom in and out. Do they help you locate the reports?

Space/time patterns

Open attribute table and select rows representing various time intervals (months, a year). Note how the report points are highlighted and see if there may be any spatial/temporal correlations.
For example, on the menu bar click Selection > Select By Attributes > Layer: reports then use the buttons and text to create a string in the SELECT window such as 

"MONTH" > 3 AND "MONTH" < 10

then Apply. You can also ‘switch’ the selection at the Options button at the bottom of the Attributes table.
DISCUSS any patterns – e.g. what did my SELECT string do.

Map the reports

Use different colors to map the points. Select reports and right-click > Properties > Symbology > Show: Categories > Unique values then Value Field: YEAR. 
Does this reveal any space/time pattern?

Pretty up the presentation. Change the labels on the Table of Contents to 1995 and 1995; make the points bigger and perhaps more boldly colored, etc.

This is an appropriate point to stop and think about what you see and have learned.

Density analysis

Enable Spatial Analyst

We next create a field (or ‘surface’) that measures the density of the reports. To do this analysis you have to have the Spatial Analyst extension activated and its toolbar visible.

Select Tools > Extensions and select Spatial Analyst then Close.

Next, go to the ArcGIS menu bar and right-click then select Spatial Analyst so that its toolbar is visible. You can move it to the menu bar.
Density surface

First, turn off all but the reports layer. Then select Spatial Analyst > Density > Input data: reports and take the defaults—and be sure to make a note of the Search radius (the default radius appears to be around 0.007).

Plot the points over this raster to see how well the density modeling worked.

DISCUSS what kind of object you just made (HINT: read ESRI help on “Understanding density analysis.” A lightly technical discussion of this technique would be an appropriate part of your assignment document—with citations!
EXTRA: Unfortunately the values of this layer aren’t very meaningful because the reports weren’t projected, but the pattern would be the same. What is the spatial unit of analysis (radius) used? If we had projected the data to Universal Transvers Mercator (UTM) meters we could correct this, but the patterns would be unchanged. You could look up information about projections, including UTM.

Map the surface

We can make the surface easier to visualize if you experiment as follows. First, select the color patch for the least-intense category then Properties >  Options: Color is Null then OK. Turn off all but the reports layers to see the correspondence. 
If you want to view the tract or map data below the intensity field right-click on Density > Properties > Display > Transparency: 30% (or any other value – experiment).
Examine the density Layer Properties > Source to look at its Properties and Values. Although some of these are technical, some should mean something and could be DISCUSSed in your assignment document.

Make a ‘finished’ map by displaying layers in the following order: report, density, tracts, raster image or map. Try to make a layout with at least a title and scale bar.

Scale analysis

You made a note of the density search radius, now make a density layer using other radii, say 4 times and ½ of the original to see the difference. What is the effect of increasing and of reducing search radius? Are different aspects of the phenomenon highlighted by these approaches?

Fix up the table of contents: present the range from highest to lowest, use 2 or 3 significant figures for the labels. 

Make an exhibit with a ‘small-scale’ surface over a ‘large-scale’ surface, which you could use in your document.
Tract analysis of reports

Choropleth map of tract data
Open the Attribute Table of the tracts layer and look at this data matrix. How many rows (tracts) and approximately how many columns? What various characteristics are being measured here? Where do you think most of the data came from?
Make a map of tract population density. Recall from the Lyme exercise that this involves Properties > Quantities > Graduated colors then selecting Value: PERSONS and Normalization: AREA.

DISCUSS: How might population density explain report density? This is a very central problem in spatial epidemiology.

EXTRA: Map another variable.  NOTE: “Z” values appear to be standardized measures reflecting the poverty rate, etc. You could make one of these maps in your document. 
Analyze counts/tract

I used ArcGIS to compute a variable called point_cnt that is the number of reports per tract. (It obviously didn’t assign all of the reports to a tract, sometimes because reports were on tract boundaries, but the vast majority of reports were correctly counted in their tracts.)
Open the tract Attribute Table and scroll right to the point_cnt  column and sort descending. Then select the top few rows to see where most of the reports are. Select all tracts with zero reports and what do you see? Sort ascending to see where the zero-report tracts are. DISCUSS these patterns.

Use identify to examine tracts with high number of reports, then zoom into a “hot” region of high-report tracts to see what may be going on.

Examine the point_cnt statistics and histogram by right-clicking on that column and selecting Statistics (the ( symbol).  Look at the histogram describing reports per tract: minimum (how many tracts?) maximum (how many reports), etc. 

Make a tract map of reports/area using the same technique as for the human density above.

EXTRA: Save both the person and point density maps as layers to compare them. Perhaps you could make a layout with both maps.

EXTRA (thought experiment): If the reports were somehow scattered randomly in the city how might this histogram appear? How would the histogram appear if all the tracts were exactly the same size (say squares or hexagons) and the reports were randomly placed? 

Choropleth map of reports per person (incidence) by tract

We next will make a tract map in which tracts will be symbolized by reports normalized by person. 
Before continuing, note that you can access the Properties of a layer by double-clicking on the layer in the Table of Contents. Do that for tracts then select Symbology > Quantities > Graduated Colors > Fields > Value: point_cnt  and Normalization: PERSONS. Left-click Label and select Reverse Sorting, then left-click Symbol and (if necessary) match the intense colors to the larger values. 
Place the reports (point layer) over this map to see the correspondence. If you study this map you should see that the ‘correlation’ is by no means perfect: there are tracts with high rates of reports/person with relatively few reports, and vice-versa. 
DISCUSS what this means, as it is central to the understanding of incidence versus density. What is the difference? between these measurements, and what are appropriate ways to map them?
In sum, discuss these various kinds of phenomena: points, density surface, reports per tract, density choropleth, incidence choropleth.
Final maps…

Select a few of the exhibits that tell us most about this phenomenon and discuss what they show.

Map the tracts with no fill and an appropriate outline to give context to the density surface and Overlay the Philadelphia outline on top of the density to make a presentable map and overlay tracts (map them with no fill). 

What we are interested in is the intensity (epidemiologists call it “incidence”) of events among the population, in this case the people of the city.

Map tracts on top of density with tracts as semi-transparent (translucent) to compare high incidence with high density – what’s the difference?

DISCUSS: What kinds of things are we analyzing and creating here: points, reports in tracts, density, incidence, etc? What’s their ‘geometry’—and ontology!
EXTRAS
Make an outline of the city by selecting the toolbox icon on the menu bar then select  Data Management > Generalization > Dissolve then Input: tracts and Output: city. This should dissolve all the tract boundaries to make a single polygon of the city. You can use this city layer to improve the appearance of your maps.
Think about the “spatial join” process. How would you go about counting the reports in each tract? There’s an obvious manual approach, but how might it be automated?

Assignment

Use the standard ‘how to write a paper’ (intro, methods, results, discussion) outline to analyze the spatial and temporal patterns of reports in the city, adding exhibits and statistics where appropriate. In particular select some of the DISCUSS paragraphs from above and elaborate on the ideas introduced.

Submit the assignment to me as a document with the usual firstinitiallastname.ext convention (e.g. jsnow.doc or jsnow.pdf or jsnow.html, etc.).
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